Home Image-Pro General Discussions

Unable to open svs image files

Hi,

We encountered a svs file that could not be opened.
Is it caused by the creation of a multi-layer?
I attach the file information for reference.




Error in Image-Pro
Failed to open file 1033359.svs.
參數錯誤。



Message: 參數錯誤。

ParamName: Nothing
Data: System.Collections.ListDictionaryInternal
InnerException: Nothing
TargetSite: MediaCy.IQL.Engine.McImage Open(System.String, Int32)
StackTrace:    at MediaCy.IQL.IO.LargeImage.IMcVLIFiles.Open(String filename, Int32 lFlags)
   at MediaCy.Viewers.LargeImage.McLargeImageController.LoadDocument(Object source, String type)
HelpLink: IQL.chm#35904
Source: McVLIFilesLib.McVLIFiles
HResult: -2147024809
Call Stack:
MediaCy.IQL.Engine.McImage Open(System.String, Int32):
Name: Open
DeclaringType: MediaCy.IQL.IO.LargeImage.IMcVLIFiles
ReflectedType: MediaCy.IQL.IO.LargeImage.IMcVLIFiles
MemberType: Method
MetadataToken: 100663300
Module: MediaCy.IQL.IO.LargeImage.dll
IsSecurityCritical: True
IsSecuritySafeCritical: True
IsSecurityTransparent: False
MethodHandle: System.RuntimeMethodHandle
Attributes: PrivateScope, Public, Virtual, HideBySig, VtableLayoutMask, Abstract
CallingConvention: Standard, HasThis
ReturnType: MediaCy.IQL.Engine.McImage
ReturnTypeCustomAttributes: MediaCy.IQL.Engine.McImage 
ReturnParameter: MediaCy.IQL.Engine.McImage 
IsGenericMethod: False
IsGenericMethodDefinition: False
ContainsGenericParameters: False
MethodImplementationFlags: 4099
IsPublic: True
IsPrivate: False
IsFamily: False
IsAssembly: False
IsFamilyAndAssembly: False
IsFamilyOrAssembly: False
IsStatic: False
IsFinal: False
IsVirtual: True
IsHideBySig: True
IsAbstract: True
IsSpecialName: False
IsConstructor: False
CustomAttributes: System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeData]
MediaCy.IQL.Application.IMcDocument LoadDocument(System.Object, System.String):
Name: LoadDocument
DeclaringType: MediaCy.Viewers.LargeImage.McLargeImageController
ReflectedType: MediaCy.Viewers.LargeImage.McLargeImageController
MemberType: Method
MetadataToken: 100663453
Module: MediaCy.Viewers.LargeImage.dll
IsSecurityCritical: True
IsSecuritySafeCritical: False
IsSecurityTransparent: False
MethodHandle: System.RuntimeMethodHandle
Attributes: PrivateScope, Public, Final, Virtual, VtableLayoutMask, CheckAccessOnOverride
CallingConvention: Standard, HasThis
ReturnType: MediaCy.IQL.Application.IMcDocument
ReturnTypeCustomAttributes: MediaCy.IQL.Application.IMcDocument 
ReturnParameter: MediaCy.IQL.Application.IMcDocument 
IsGenericMethod: False
IsGenericMethodDefinition: False
ContainsGenericParameters: False
MethodImplementationFlags: Managed
IsPublic: True
IsPrivate: False
IsFamily: False
IsAssembly: False
IsFamilyAndAssembly: False
IsFamilyOrAssembly: False
IsStatic: False
IsFinal: True
IsVirtual: True
IsHideBySig: False
IsAbstract: False
IsSpecialName: False
IsConstructor: False
CustomAttributes: System.Collections.ObjectModel.ReadOnlyCollection`1[System.Reflection.CustomAttributeData]




Best regards,

Wesan 

Best Answer

  • Accepted Answer
    We are working on a fix for your problem SVS files.  The issue is two-fold.  The example file you posted has multiple sets of multi-resolution image data, and further, the first set of sub-images has 3 resolutions while the rest have only two.  We are not likely to ever support reading all of this data, but we can probably support reading the first set of 3 resolutions as a single-frame image (ignoring the rest of the frames).

    In short, the issue is support for multiple frames of multi-resolution pixel data packed into the same SVS file.  The best solution for you, if you can do it, is to save your slide as a single image frame SVS (we should be able to open that now) or as a sequence of frames as a TIFF file with no sub-resolutions (we should be able to open that too, if the frames are not too large).

Answers

  • Hi Wesan,

    We will need the image to check the problem. Is there a way you can share this or a smaller sample that have the same problem?

    Thanks,

    Yuri
  • Hi Yuri,

    Please refer to the attached file.  Thank you.


    Best regards,
    Wesan 
  • Hi Wesan,

    Thank you for the test image. We can reproduce the problem reading the file and will look at the issue.
    I will let you know when we have an update for this.

    Regards,

    Yuri
  • Hi Yuri,

    I have upgraded IP10 to version 10.0.9.
    But it still shows same error when open multi-layer svs files.
    May i know when will this problem be solved?
    Thank you.

    Best regards,
    Wesan 
  • Wesan, the current Image-Pro version, 10.0.10, should now be able to open the first frame of your multi-frame SVS images; subsequent frames are ignored.  Please let us know if this works for you with all of your SVS files.  We only had the one image you posted for testing.

    Thank you for reporting this and supply the test file.

    Craig.
Sign In or Register to comment.