Home Image-Pro Plus General Discussions

ROI not saving


I'm asking for a colleague who has saved all of his ROI's in the feature manager rather than on the image. When applying the ROI from the feature manager, doing analysis and then saving and closing the image, the ROI does not save. So next time the image is opened, the counting of cells (smart segmentation) is still there, but the ROI is gone, so the cell count is made all over the image rather than in the confined area. How do we get about that the ROI is saved on the image? We need to apply the ROI to be able to use it in the Cell analysis app. 

He is analyzing blood vessels in IHC-sections by staining the endothelial cells. We have used the "fill holes" option to include the lumen in the count as well, but, in some cases, the endothelial cells around the lumen are not stained in a way that the lumen is fully encircled by stained cells. Is there a clever way to "close" the cirkel and get the program to count the lumen anyway? 




  • In the Options dialog on the "File" page is a "Save ROI's" check box.  If that is not checked, then the ROI will not be saved when the image is saved.  Is this option checked for your colleague?
  • Hi Craig!

    Yep, that box is ticked...still doesn't save...
  • And now the same thing is happening to my images, but with freshly drawn ROIs...whats wrong? Neither save, nor save as works!
  • You are saving the file as a TIF file aren't you?  ROI's (and other metadata such as Annotations) are only saved for the TIF file format.  If you save an image as a JPG, these metadata will be lost.
  • Yep, saving as TIF. 
    Smart segmentation is saved, as well as counts within the ROI, except the outlines of the ROI are not there anymore...

    When will IPP 9.2 be released? Maybe it will just miracoulously fix it self when we upgrade? :smiley: 

    I will continue to try fix it today...
  • I did some test-runs today and tried getting the RIO's to stick by ticking the "crop to ROI with save as"-box and that seems to work, unfortunately I need the whole picture saved for analysis. Right after I tried the crop-version I tried saving a quickly drawn ROI with the crop-box unticked and it actually saved. So I did a proper ROI for the picture and that one failed to save. I've tried both save as and save, none seems to save the ROI. I've tried both our computers (two different licenses), it wont save ROI on either. Any other ideas to what we could have messed up in terms of ticking or unticking boxes? 
  • I cannot reproduce your problem, but I'm using 9.2 code and Yuri tells me that your images are very large with many measurement results, so we may be working with apples and oranges.  Until we can get you 9.2, here's one more thing to try:

    In the Options dialog on the "Task Scheduling" page, uncheck "Batch Process All" and see if that fixes the ROI saving problem.  The effect will be to execute the file saving code in the foreground thread (as well as all filters, etcetera).
  • Maybe I'll just have to wait and hope for 9.2...

    At first your suggestion to untick the batch process all looked like it worked! I tried one image and I could save an open a picture with an roi.

    I then tried it with one of my colleagues images, with the roi from the features manager and all I got was an error saying that the source is invalid. I also tried this with one of my images, where it had previously worked, and got the same message...I used the save as for my image, so at least I still have the original tiled image saved. However, with my colleagues image I only just saved it, and now I cannot open that image in Ipp at all...I havn't tried opening it outside of Ipp, I will try that in the morning when I'm back at work!

    Any clue to why this is happening? Are the images to large? Or is it something else? 

Sign In or Register to comment.