Home Image-Pro General Discussions

Unable to crop additional images

Once I open a saved image and crop out one field I am unable to crop any additional fields...I just get a black image. I have tried closing the first cropped image extracted, cropping out the same ROI, choosing a new ROI, etc.  The only way to get another image cropped out is to close the larger file and re-open it.  I have never had this problem before. Is this a glitch from the upgrade?

Best Answer

  • Answer ✓
    rtaliano --

    I am running the same version of PREMIER that you are and this behavior does not happen on my computer.

    A SCREEN CAPTURE of a CROP done on the LEFT SIDE of an ORIGINAL (then the CROP was saved) then a CROP was done on the RIGHT SIDE of the ORIGINAL.

    Are there any PROJECTS loaded within your PREMIER?

    If so, can you:

        ** REMOVE the PROJECTS
        ** RESTART your PREMIER
        ** TEST the CROP and SAVE

    If the CROP and SAVE behaves differently with and without PROJECTS, then the PROJECTS are meddling in the process.

    I hope this information is helpful.

    -- Matt


  • Hi rtaliano,

    Please, let us know few details of the issue:
    1) What is product? Version?
    2) What is the image or an image set? 
    3) What is the view?


  • Image Pro Premier 9.1.4 Build 5638. Not sure what you mean by image, image set or view. Just gives me black image in main window and in image strip with otherwise appropriate info like size in pixels, RGB, etc
  • What is the image extension?
  • I have a test image from you from an earlier question: "Malaria fixed crop scan.svs", which is an Aperio SVS format 24-bit RGB image.  For me (16GB memory), this opens into a Large Image workspace, and I was able to select a ROI, extract that ROI at 1-1 resolution, move the ROI and repeat successfully.  I was also able to to the same test with smaller images, doing a crop instead of the Large Image workspace extract.

    From your earlier question, I remember that you have a lot of memory, so that this 15GB image may open as into an ordinary (not Large Image) workspace.  Is this the case for the image you are having trouble cropping from?
  • Due to a problem with the Aperio files apparently not being in correct format I switched to leica format...which appears to work fine....images open appropriately as VLI.  I have been using these for about 2 weeks now and until today have not had a problem extracting multiple small images from the larger file. Since the source image is much smaller than the ones I had sent they are not opening in VLI all of the time as I am saving much smaller fields from the scanner. I could try adjusting memory down to force them to open as VLI and try extracting from there but I have not had any prior problems extracting either way before. And the resource monitor does not indicate that I am using a large amount of memory as was previously happening with the svs files.

    I must say however, that the program is acting quite strangely at times for the first time...like refusing to allow me to select an area for background during smart segmentation. The button refuses to stay active. I have had to close the program and open the file again to do smart segmentation. And it gets very bogged down trying to save files for autorecovery. I thought this might be the result of it trying to save the larger file but it appears to be hung up on the "crop" image...which is quite small.
  • You can disable autorecovery feature in the options dialog if it is not important for you.
  • I saw that and plan to do that. Thanks
  • It sounds like something has gone wrong with your particular system very recently.  You are using the same version of Image-Pro Premier that you have been using for the last two weeks and opening the same image files (I do hope you have tested the problem on an image that worked last week).  Furthermore, it sounds like more than just image cropping is malfunctioning.  So..

    • Are any other programs malfunctioning?
    • Does the Task Manager show anything abnormal about CPU or Memory usage (e.g., Premier or some other program hogging too much.)?
    • Does the problem happen immediately after starting Premier or does it develop over time?
    • Does rebooting you system help?
    • Is your hard disk getting very full?
    • And so on.
    If all of that looks normal, then we can give you instructions for wiping out your identity, so that Premier starts in a totally reset state.
Sign In or Register to comment.