Home Image-Pro General Discussions

Problem With Tiling When I Crop Sequence of Images

I am trying to auto tile with pattern matching many images (smallest - 1x 28; largest 7 x 101). Here is my process
-I merge individual tiff files into a sequence file
-All the images have an information border at top and bottom, so I crop to a new sequence file
-I select tiling and add all images from cropped sequence file
-I select arrange by rows and enter in "Column" field 1 for smaller image; 7 for larger image. Here is the first indication there is a problem - The "Row" field normally auto updates with 28 or 101, but for the cropped sequence case it does not.
-I then select pattern matching and click on "Auto" but Nothing happens for the cropped sequence.

Is this a problem with the software or am I doing something wrong?

Other notes
-I have also tried exporting cropped sequence out to individual tiff files and recreating sequence with no luck.
-Occasionally, it figures things out and auto updates row and everything works, but I cannot figure what I did different in my process.


  • Hi Sean,

    Please verify number of frames in the cropped sequence. Try to activate "Boundaries" and "Show Info" options to clear see frames if they are dark on dark background. If possible, share screenshot, image sequence.

  • I have turned on boundaries and Show info and everything looks in order. The images look like they are arranged properly and are all there. Column # filled; Row # blank and grayed out. Really confused why it works when I make sequence from raw images, but does not work when I make sequence from cropped images.

    Unfortunately it is difficult to transmit image since I am air-gapped to internet.
  • Hi Sean,

    It's difficult to guess what the problem is without a screenshot, but it looks like you have selected "By Rows" align mode:

    When images have XY position info, the default align mode is XYZ. If images don't have position info, the XYZ option is disabled.


  • Hi Yuri

    I am now trying to work with a 72 image sequence and want 12 rows by 6 columns. When I select "By Rows" I can set columns field to 6 but rows field is blank and grayed out. XYZ is grayed out as expected. Even when i set columns field to 1, rows field is blank and grayed out. If I click on auto twice, I get following message:

    "Unsupported Tile Pattern - Tile pattern has different number of columns per row, which is not supported by automatic tiling. Please rearrange the tiles or reset layout and try again"

    Also note tiled images looks as expected on screen. I have turned on boundaries and show info - I get a 6 x 12 grid and Frame #1 through Frame #72 overlay on the grid.

    Funny thing is if I create an image sequence from my original images tiling works as expected. Problem is the original images have a black header bar at top and bottom I have to crop out. So I crop the whole sequence and try tiling new cropped sequence and I get the issues I have identified.

    I have even saved out cropped images frame by frame (tif and jp2) and then recreate sequence and still have problem. Is there some metadata that is being placed in cropped images that is causing confusion for tiling tool?

    Can you try and replicate my process - create sequence >> crop to new sequence >> tile new sequence


  • Sean,

    "Unsupported pattern" means that the image cannot be automatically stitched,  number of tiles per row is different, or there is no overlap. You may try to change Gap and Overlaps to have tiles look well-aligned.

    Cropping and tiling my test sequences work correctly.

    Seeing your screenshot would make easier to understand the issue. Even better if you could share your dataset, if it's large, I can give you an upload link.


  • OK. So i tweaked the row overlap up ad down 5-10 pixels and at a certain point row and column fields filled in with expected numbers. I was able to run the auto stitch routine and it worked.  I tested it on 2 image sequences (one 72 and other 630 images) and got both to work. I am surprised it is this sensitive, but at least now I know how to make it work!

    Thanks for your help.

  • Sean,

    To find the right overlap values you can use the following steps:

    1. Adjust Gap X/Y (use negative values) until the overlap looks correct visually.
    2. Set the Gap values as Overlap (only positive).


Sign In or Register to comment.