Home Image-Pro Automation (Macros, Apps, Reports)

REVIEW + SNAP TOOL is not working for large image . . .


All --

I am working with a large RGB IMAGE in IMAGE-PRO 10.0.2.  The dimensions are approximately 26,000 pixels wide and 28,000 pixels high.

The REVIEW + SNAP TOOL does not seem to be working on this image.

When I open a smaller (2000 x 2000) image into IMAGE-PRO (with the LARGE IMAGE still open) the REVIEW + SNAP TOOL works fine.

Is there an upper limit on the size of an image that will work with the REVIEW + SNAP TOOL?


-- Matt


  • 2019-03-20-104142

    All --

    Is there a way to use the


    on a VERY LARGE IMAGE or is the only solution to reduce the dimensions of the image?

    Also, it may be good to add a message to the

        SNAP TOOL

    to announce that the TOOL cannot process an image due to its size.

    -- Matt

  • Matt,

    Snap tool tries to create image with 100% zoom, so if your image is big, it may fail due to lack of RAM.
    There is another button "View" (next to Snap) which creates a snapshot of the window with given zoom. 
    Will it work for you? Otherwise you have to either resize the image or Extract image with smaller resolution (using VLI toolbar).

  • 2019-03-21-091156

    Yuri --

    Thank you for your guidance.

    I worked with the REVIEW RIBBON + VIEW TOOL and it may be a solution.  Thank you for introducing me to this TOOL.

    I looked into the VLI TOOLBAR via


    I see info starting on PAGE 259 but my attempts to work with these TOOLS was not a success.  My TOOL RIBBON (in 10.0.2) does not change when I open a VERY LARGE IMAGE (dimensions = 26K+ x 28K+) image (from JPG or TIF file).  I think this is because I am dealing with a "flat image" that does not fit the requirements shown in the PDF as:
    • The image file contains multiple resolution images of the same subject matter, from a whole-image thumbnail through other subsampled resolutions up to the native resolution that was originally captured, and
    • The image file supports tiled/random access to portions of the image.
    The computer I am working with has 16 GB of RAM.  With IP 10.0.2 open with no images, 6.72 GB are occupied (per TASK MANAGER / PERFORMANCE / MEMORY).  Opening the EXAMPLE IMAGE (24 BIT RGB, 26136 x 28383) 10.7 GB are occupied.  In this situation the SNAP TOOL does not work but the CROP (with no ROI) will duplicate the entire image.  After the duplication, the TASK MANAGER says 12.7 GB are occupied.

    I just tried to make a MASK of the MEASUREMENT FEATURES that I thought might be used in and ARITHMETIC OPS with the DUPLICATE IMAGE and IP 10.0.2 choked.  In this case there were more than 700,000 MEASUREMENT FEATURES (LARGE IMAGE with SMALL FEATURES).

    Any thoughts?


    -- Matt

  • edited March 2019
    Hi Matt,

    You have several separate issues in the last question.
    1. VLI tools will only show if the image is loaded from multi-resolution file. If you load it from JPEG, than it's just a flat image.

    2. Snap operation, besides duplicating, also merges all overlays and applies LUT creating a new 24bpp image, so it may require more RAM than just Crop.

    3. 700.000 measurement objects also require RAM, so if you just need a mask, you may think about some other, more efficient way of doing it, if possible. For example, you can create a mask directly from Threshold tool or Smart segmentation.


  • 2019-03-21-141950

    Yuri --

    Thank you for your response.

    1)  Perhaps a better name for the VERY LARGE IMAGE TOOLS would be MULTI RESOLUTION IMAGE TOOLS.

    2)  SNAP does seem to have some issues with VERY LARGE IMAGES and when it fails there are no ERROR MESSAGES.  I opened the EXAMPLE IMAGE that I have been describing and cleared all MEASUREMENT OBJECTS and then did a CROP on the ENTIRE IMAGE which succeeded and a SNAP on the ENTIRE IMAGE which failed with no error even though there were no OBJECTS and no LUTS to handle.

    3)  I can CROP / DUPLICATE the EXAMPLE IMAGE and run the same THRESHOLD + COUNT on the NEW IMAGE so that both VERY LARGE IMAGES have 700K+ OBJECTS so IP is capable of holding two copies of this image with measurement objects but the SNAP TOOL gets derailed someplace.  I do not seem able to put the MEASUREMENTS from the ORIGINAL or the NEW IMAGE into the FEATURE MANAGER or open the DATA TABLE though.  Perhaps this is where the issue lies.

    I think that I can achieve my goal with the VIEW TOOL.  Unfortunately the result of the VIEW TOOL is limited by the resolution of the screen that IP is running on and the RESOLUTION / CALIBRATION of the VIEW TOOL IMAGE RESULT is variable.

    Thanks again for the assistance.

    -- Matt

Sign In or Register to comment.